Errorgalore

Hmz. Al een ganse voormiddag loop ik vast op volgende fout bij het compileren van de GIMP onder windows…

checking for pkg-config... /mingw/bin/pkgconfig
checking for GLIB - version >= 2.8.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error: Test for GLIB failed. See the file 'INSTALL' for help.

Knars, knars…

4 replies

  • Waarom neem je de voorgecompileerde versie niet? (http://www.gimp.org/windows/)

    Of probeer je te compileren onder cygwin? Dan lijkt het me dat je de juiste Glib niet staan hebt. En wat is het resultaat van configure.log of de log van make?

  • Matthias

    29 november 2005 at 5:08 pm

    Wel. Ik wil een plugin compileren voor windows. Dus dat wil zeggen: ontwikkelomgeving opstarten, etc.

    Ik doe het via deze tutorial. Dus binnen MSYS en niet via cygwin.

    Het heeft wel zijn eigenaardigheden. En die fout met glib is eentje waar ik steeds over struikel. Ik had ze ooit eens getackeld, maar toen moest ik opgeven omwille van andere prioriteiten… tsss…

  • Matthias

    30 november 2005 at 12:58 pm

    Bon. Wat spelen met de flags in .profile ben ik wat verder. Nu krijg ik een error over één of andere flag in gcc die verkeerd is (-03 in plaats van -O3).

  • Matthias

    30 november 2005 at 2:53 pm

    O3 flag probleem ook al opgelost.

    Nog altijd geen oplossing. Dit is nu wat ik krijg in mijn config.log

    configure:25764: gcc -o conftest.exe -03 -fsigned-char -Wall -mms-bitfields conftest.c >&5
    c://ccILaaaa.o(.text+0x32):conftest.c: undefined reference to '_imp_glib_major_version'
    c://ccILaaaa.o(.text+0x32):conftest.c: undefined reference to '_imp_glib_minor_version'
    c://ccILaaaa.o(.text+0x32):conftest.c: undefined reference to '_imp_glib_micro_version'
    collect2: ld returned 1 exit status
    gcc.exe: unrecognized option '-03'
    configure:25770: $? = 1
    configure: failed program was:

    Heb hier een nota achtergelaten…

Commentaar is gesloten